IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
Incident is now resolved. We will continue to monitor performance. Thank you for your patience.
Posted Apr 04, 2022 - 07:26 PDT
Monitoring
We have implemented changes to address the underlying issue and are currently monitoring results. We are seeing performance improve as we move towards a full resolution. We will have more updates soon. Thank you for your patience.
Posted Apr 04, 2022 - 06:42 PDT
Investigating
We are investigating an issue that prevents access to IT Glue in our North American Data Center. You may see 502 Bad Gateway or other error pages on accessing the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Apr 04, 2022 - 06:35 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.