Degraded Performance - IT Glue - North America
Incident Report for IT Glue
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 09:29 PDT
Monitoring
A fix has been implemented, we are currently monitoring and seeing an improvement in response times in the application including passwords. We will have more updates for our customers as they become available.
Posted Aug 17, 2023 - 08:28 PDT
Identified
The issue has been identified and we are currently working on a fix. We will share more information as soon as we have them.
Posted Aug 17, 2023 - 07:42 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue passwords and other pages for some of our partners. You may see error pages upon accessing them. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Aug 17, 2023 - 07:19 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.