Degraded Performance - IT Glue - North America
Incident Report for IT Glue
Resolved
This incident has been resolved. Thank you for your patience as we worked hard behind the scenes.
Posted Nov 29, 2022 - 08:32 PST
Monitoring
We are currently monitoring the results of the applied fix as app performance is restored.
Posted Nov 29, 2022 - 08:20 PST
Identified
The issue has been identified and a fix put in place. We are starting to see performance return to normal. We will have further updates as soon as we can.
Posted Nov 29, 2022 - 08:14 PST
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Nov 29, 2022 - 07:57 PST
This incident affected: North America Primary Application Services and North America Primary File Services.