IT Glue Unavailable - 502 Bad Gateway - North America
Incident Report for IT Glue
Resolved
This incident has been resolved. Thank you for your patience as we worked hard behind the scenes.
Posted Jul 18, 2023 - 12:46 PDT
Monitoring
A fix has been implemented and we are currently monitoring performance of the IT Glue application. Users will be able to access the application again.
Posted Jul 18, 2023 - 12:35 PDT
Identified
The issue has been identified and we are working on a fix. Users will be getting a 502 Bad Gateway error when accessing the application.
Posted Jul 18, 2023 - 12:17 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Jul 18, 2023 - 11:54 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.