Recent Items currently disabled - North America
Incident Report for IT Glue
Resolved
Recent Items functionality is now completely restored
Posted 7 months ago. Jul 06, 2018 - 11:40 PDT
Identified
In order to resolve some performance issues this morning, we have had to temporarily remove the feature 'Recent Items' from IT Glue. We are working to replace the feature as soon as we can, please check here for updates.
Posted 8 months ago. Jul 05, 2018 - 11:00 PDT
This incident affected: North America Primary Application Services.