Degraded Performance - IT Glue - North America

Incident Report for IT Glue

Resolved

This incident has been resolved.
Posted Nov 04, 2024 - 14:07 PST

Monitoring

A fix has been implemented and we are currently monitoring the performance. Thank you for your patience as we continue to monitor.
Posted Nov 04, 2024 - 12:37 PST

Update

We are continuing to work on a fix for this issue. Thank you for your patience as we work behind the scenes.
Posted Nov 04, 2024 - 10:36 PST

Identified

We are investigating degraded performance in IT Glue for our partners in our North American DC. You may see delays or errors when accessing pages. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Nov 04, 2024 - 09:44 PST
This incident affected: North America Primary Application Services and North America Primary File Services.