Degraded Performance - North America
Incident Report for IT Glue
Resolved
We are pleased to say the issue has been resolved.
Posted 7 months ago. Mar 26, 2019 - 16:21 PDT
Monitoring
Response times are back to normal performance levels. We are currently monitoring.
Posted 7 months ago. Mar 26, 2019 - 16:00 PDT
Identified
The issue has been identified and our DevOps team are working diligently on a resolution.
Posted 7 months ago. Mar 26, 2019 - 15:25 PDT
Investigating
We are investigating performance issues that may prevent access to certain IT Glue assets and features for some of our partners.

Region: North America
Applications: Web App, Mobile App, Chrome Extension, Search
Posted 7 months ago. Mar 26, 2019 - 14:55 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.