IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
The IT Glue Application has resumed normal operation, Incident resolved. We will continue to monitor performance.
Posted 5 months ago. May 14, 2019 - 08:28 PDT
Monitoring
A fix has been implemented and we are currently monitoring the results and performance.
Posted 5 months ago. May 14, 2019 - 08:01 PDT
Investigating
We are investigating some performance issues presently, that may prevent access to IT Glue for some of our partners.
Posted 5 months ago. May 14, 2019 - 07:13 PDT
This incident affected: North America Primary Application Services.