IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
Incident is now resolved. We will continue to monitor performance. Thank you for your patience as we worked hard behind the scenes.
Posted Nov 29, 2021 - 10:59 PST
Monitoring
A fix has been implemented. Users will be able to access IT Glue at this point as we move towards a full resolution. Thank you for your patience as we continue to monitor and address as required.
Posted Nov 29, 2021 - 10:45 PST
Identified
The issue has been identified as we continue to investigate further. We will have more updates here as we have them.
Posted Nov 29, 2021 - 10:22 PST
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error 502 Bad Gateway in the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Nov 29, 2021 - 09:50 PST
This incident affected: North America Primary Application Services and North America Primary File Services.