IT Glue Platform Unavailable - Europe
Incident Report for IT Glue
Resolved
IT Glue application has resumed normal operation. Incident resolved. We will continue to monitor performance.
Posted 6 months ago. Apr 09, 2019 - 06:30 PDT
Investigating
We are investigating performance issues at the moment, that may prevent access to IT Glue for some of our partners.
Posted 6 months ago. Apr 09, 2019 - 06:09 PDT
This incident affected: European Union Primary Application Services.