IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
Incident is now resolved. We will continue to monitor performance.
Posted May 11, 2022 - 12:48 PDT
Update
Incident is now resolved. We will continue to monitor performance.
Posted May 11, 2022 - 12:47 PDT
Monitoring
We have implemented changes to address the underlying issue and are currently monitoring the results. We are seeing performance improvements as we move towards a full resolution. We will have more updates soon. Thank you for your patience.
Posted May 11, 2022 - 12:27 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see 502/500 error pages on certain pages in the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted May 11, 2022 - 12:20 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.