Degraded Performance - IT Glue - Australia
Incident Report for IT Glue
Resolved
This incident is now resolved. Thank you for your patience as we worked to get this addressed.
Posted Mar 16, 2023 - 13:00 PDT
Monitoring
A fix has been implemented and we are monitoring results.
Posted Mar 16, 2023 - 12:57 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app or accessing some assets. We will provide further details here as soon as we can.

Region: Australia
Applications: Web App
Posted Mar 16, 2023 - 12:46 PDT
This incident affected: Australia Primary Application Services and Australia Primary File Services.