Password list view fails to load on initial visit
Incident Report for IT Glue
Resolved
We are pleased to say the issue has been resolved and the password view is now working correctly.
Posted 11 months ago. May 18, 2018 - 14:14 PDT
Identified
On logging into a new session in IT Glue, selecting Passwords from the left menu does not load the list view as expected. This was caused by an addition in our most recent release. We are working on resolving this issue as quickly as possible, please check here for updates.

When you experience this issue, refresh the browser page, using F5 (Windows), CMD R (Mac), or select View > Reload page from the browser menu, and the password page will work normally with full functionality.

During any one browser session, you will now experience normal functionality. Should you sign out or restart your browser, you will need to repeat the Refresh step above once for the new session.
Posted 11 months ago. May 18, 2018 - 08:47 PDT