IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
AWS has confirmed that the issues have been resolved on their end, as such we are also not receiving any further reports or errors. This incident is now considered resolved. Thank you.
Posted Dec 15, 2021 - 08:43 PST
Monitoring
Initial investigation shows AWS has been having internet connectivity issues in multiple regions that is now in the process of being resolved by their team. As a result, we are seeing app accessibility return back to normal. We will continue to monitor till full resolution. Thank you for your patience.
Posted Dec 15, 2021 - 08:21 PST
Investigating
We are investigating reports of issues that may prevent access to IT Glue for some of our partners. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Dec 15, 2021 - 07:52 PST
This incident affected: North America Primary Application Services and North America Primary File Services.