Degraded Performance - IT Glue - North America
Incident Report for IT Glue
Resolved
This incident has been resolved, we will continue to monitor performance.
Posted Aug 30, 2022 - 09:20 PDT
Monitoring
We are currently monitoring app performance after seeing improved performance. We thank you for your patience as we continue to monitor.
Posted Aug 30, 2022 - 09:00 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Aug 30, 2022 - 08:40 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.