Degraded Performance - IT Glue - North America
Incident Report for IT Glue
Resolved
This incident is now resolved. Thank you for your patience as our team worked behind the scenes to address this.
Posted Mar 17, 2023 - 09:12 PDT
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Mar 17, 2023 - 08:39 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app or pages not load with all elements. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Mar 17, 2023 - 08:09 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.