IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
Incident is now resolved. We will continue to monitor performance. Thank you for your patience as we keep working hard behind the scenes.
Posted Mar 31, 2022 - 08:12 PDT
Monitoring
Users will be able to access IT Glue at this point as we move towards a full resolution. Some users may see intermittent errors accessing the app. Thank you for your patience as we continue to monitor and address as required. We will have more updates soon.
Posted Mar 31, 2022 - 07:28 PDT
Update
We are continuing our work on a fix to restore full app functionality diligently. Some partners may see intermittent errors at this point. We apologise for the inconvenience caused due to this service interruption.
Posted Mar 31, 2022 - 06:53 PDT
Identified
We have identified the issue and are working on a fix.
Posted Mar 31, 2022 - 06:08 PDT
Investigating
We are investigating an issue that prevents access to IT Glue in our North American Data Center. You may see 502 Bad Gateway or other error pages on accessing the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Mar 31, 2022 - 05:51 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.