IT Glue Platform Unavailable - North America
Incident Report for IT Glue
Resolved
Incident is now resolved. We will continue to monitor performance. Thank you for your patience as we worked hard behind the scenes.
Posted Aug 11, 2021 - 07:14 PDT
Monitoring
A fix has been implemented and we are currently monitoring for any errors. Users will be able to access IT Glue at this point. Thank you for your patience as we continue to monitor.
Posted Aug 11, 2021 - 06:44 PDT
Identified
The issue has been identified and a fix is being implemented. Thank you for your patience.
Posted Aug 11, 2021 - 06:17 PDT
Investigating
We are investigating reports of 504 Gateway Timeout errors that may prevent access to IT Glue in our North American Data Center. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Aug 11, 2021 - 05:32 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.