Degraded Performance - IT Glue - North America
Incident Report for IT Glue
Resolved
Incident is now resolved. We will continue to monitor performance.
Posted Mar 15, 2022 - 13:34 PDT
Monitoring
We are monitoring performance as we see improvement in the app.
Posted Mar 15, 2022 - 13:18 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see 502 Bad Gateway error pages on certain pages in the app or general slowness. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted Mar 15, 2022 - 12:53 PDT
This incident affected: North America Primary Application Services and North America Primary File Services.