Performance slow or IT Glue unavailable - North America
Incident Report for IT Glue
Resolved
IT Glue application has resumed normal operation. Incident resolved.
We have had to once again temporarily remove the Recent Items feature while we work on a long term fix.
Posted about 1 year ago. Jul 17, 2018 - 15:44 PDT
Investigating
We are investigating performance issues that may prevent access to IT Glue for some of our
partners.
Posted about 1 year ago. Jul 17, 2018 - 15:31 PDT
This incident affected: North America Primary Application Services.