IT Glue Unavailable - Europe
Incident Report for IT Glue
Resolved
IT Glue application has resumed normal operation. Incident resolved. We will continue to monitor performance.
Posted 8 months ago. Dec 13, 2018 - 03:57 PST
Investigating
We are investigating performance issues at the moment, that may prevent access to IT Glue for some of our partners.
Posted 8 months ago. Dec 13, 2018 - 03:46 PST
This incident affected: European Union Primary Application Services.